No Code Attached Yet
avatar garrett02
garrett02
14 Dec 2015

Steps to reproduce the issue

Login with Active Directory LDAP Authentication to joomla site.

Expected result

Login Successful

Actual result

Login Successful, however PHP Error Generated as follows for each successful/unsuccessful login attempt:
"Uninitialized string offset: 0 in ............\libraries\joomla\user\helper.php on line 341"

System information (as much as possible)

PHP 5.6 w/ IIS 8.5 on Win 2012 r2, Active Directory, Joomla 3.4.5

Additional comments

At the request of the poster who helped me solve this, I am posting as an issue. By changing the order of authentication plugins such that LDAP was placed before Joomla!, I was able to mitigate this error from occurring.
http://forum.joomla.org/viewtopic.php?f=708&t=902366

avatar garrett02 garrett02 - open - 14 Dec 2015
avatar anabarcellos
anabarcellos - comment - 7 Apr 2016

@garrett02 Same issue here.
I use the same LDAP configuration in dozens of sites and just one of them had this problem. It was in Joomla 2.5.28. Updated to 3.5.1 but the issue was still there. I solved it changing the order of authentication plugins as suggested in the forum post that you shared (thank you).

SLES11 - PHP 5.3


This comment was created with the J!Tracker Application at issues.joomla.org/joomla-cms/8685.

avatar brianteeman brianteeman - change - 13 Apr 2016
Category Authentication IIS Authentication
avatar brianteeman
brianteeman - comment - 13 Apr 2016

Removed IIS tag as second post shows it is not server related


This comment was created with the J!Tracker Application at issues.joomla.org/joomla-cms/8685.

avatar brianteeman brianteeman - change - 10 May 2016
Status New Confirmed
avatar rvbgnu
rvbgnu - comment - 3 Jun 2017

Hi @garrett02 is this issue still relevant? Or is the mention of the solution in the forum enough?
@nibra

avatar franz-wohlkoenig franz-wohlkoenig - change - 3 Jun 2017
Status Confirmed Information Required
avatar franz-wohlkoenig
franz-wohlkoenig - comment - 3 Jun 2017

set Status on "Information Required".


This comment was created with the J!Tracker Application at issues.joomla.org/tracker/joomla-cms/8685.

avatar joomla-cms-bot joomla-cms-bot - edited - 3 Jun 2017
avatar franz-wohlkoenig
franz-wohlkoenig - comment - 22 Jun 2017

If this PR get no Response, it will be closed at 23th July 2017.

avatar garrett02
garrett02 - comment - 22 Jun 2017

I think the mention of solution in the forum is sufficient for most.

avatar franz-wohlkoenig
franz-wohlkoenig - comment - 22 Jun 2017

thanks for Info, @garrett02, can you please close this Issue?

avatar garrett02 garrett02 - change - 22 Jun 2017
Status Information Required Closed
Closed_Date 0000-00-00 00:00:00 2017-06-22 12:13:29
Closed_By garrett02
avatar garrett02 garrett02 - close - 22 Jun 2017

Add a Comment

Login with GitHub to post a comment