No Code Attached Yet
avatar richard67
25 Apr 2020

Steps to reproduce the issue

Since commit 683793d the AppVeyor CI tests are failing for PHP versions >= 7.2 on the staging branch.

Expected result

AppVeyor CI tests succeed.

Actual result

AppVeyor CI tests fail.

System information (as much as possible), or

Additional comments

The "error" message "Your Composer dependencies require a PHP version ">= 5.3.10" and "< 7.2.0". You are running ..." at the bottom of each log is misleading, is also comes when a build has run with success.

avatar richard67 richard67 - open - 25 Apr 2020
avatar joomla-cms-bot joomla-cms-bot - change - 25 Apr 2020
Labels Added: No Code Attached Yet
avatar joomla-cms-bot joomla-cms-bot - labeled - 25 Apr 2020
avatar richard67
richard67 - comment - 25 Apr 2020

Ping @zero-24 as agreed.

avatar richard67 richard67 - change - 25 Apr 2020
Category Unit Tests
avatar richard67 richard67 - change - 25 Apr 2020
The description was changed
avatar richard67 richard67 - edited - 25 Apr 2020
avatar zero-24
zero-24 - comment - 29 Apr 2020

We might try here:

composer install --ignore-platform-reqs ?

And see whether it is a workaround.

What do you think @rdeutz

avatar zero-24
zero-24 - comment - 30 Apr 2020

Here is the proposed PR: #28890 please do not close here right now as I'm not sure whether that PR works out.

avatar zero-24
zero-24 - comment - 10 May 2020

As my proposed fix does not fix the issue i have just closed the PR so this Issue here should stay open to track the issue. So someone who has more knowledge with appveyor can take a look here. Thanks.

Add a Comment

Login with GitHub to post a comment