No Code Attached Yet
Related to # 15674
avatar elpescador-nl
elpescador-nl
26 Apr 2017

Steps to reproduce the issue

Enable plugins languagefilter and (page) cache and use SEF-urls.

Expected result

I would expect when I go to example.com/ I will be redirected (302) to the default language or to the one stored in my cookie: example.com/nl/

Actual result

I remain on example.com/ with a blank page (http 200).

System information (as much as possible)

PHP Version: 7.0.12
Web Server: nginx/1.11.4
WebServer to PHP Interface: cgi-fcgi
Joomla! Version Joomla! 3.7.0 Stable [ Amani ] 25-April-2017 15:36 GMT
Joomla! Platform Version: Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT

Tested this behaviour in Safari and Google Chrome. Does not seem browser related.

Additional comments

When I disable page cache plugin the redirect works however. To me it seems an issue with the page cache mechanism which prevents the redirect somehow.

avatar elpescador-nl elpescador-nl - open - 26 Apr 2017
avatar joomla-cms-bot joomla-cms-bot - labeled - 26 Apr 2017
avatar franz-wohlkoenig franz-wohlkoenig - change - 26 Apr 2017
Category Multilanguage Plugins Router / SEF com_cache Multilanguage Plugins Router / SEF
avatar AlexRed
AlexRed - comment - 26 Apr 2017

I can confirm the problem


This comment was created with the J!Tracker Application at issues.joomla.org/tracker/joomla-cms/15579.

avatar franz-wohlkoenig franz-wohlkoenig - change - 26 Apr 2017
Status New Confirmed
avatar PhilETaylor
PhilETaylor - comment - 26 Apr 2017

is #15593 related?

avatar elpescador-nl
elpescador-nl - comment - 26 Apr 2017

@PhilETaylor , probably: yet another situation with the same problem: no redirection when cache plugin is enabled.

avatar manuel-reil
manuel-reil - comment - 27 Apr 2017

Confirmed here as well.

avatar franz-wohlkoenig franz-wohlkoenig - change - 29 Apr 2017
Status Confirmed Closed
Closed_Date 0000-00-00 00:00:00 2017-04-29 08:21:09
Closed_By franz-wohlkoenig
Rel_Number 0 15674
Relation Type Related to
avatar joomla-cms-bot joomla-cms-bot - close - 29 Apr 2017
avatar joomla-cms-bot
joomla-cms-bot - comment - 29 Apr 2017
avatar franz-wohlkoenig
franz-wohlkoenig - comment - 29 Apr 2017

closed as related to #15674


This comment was created with the J!Tracker Application at issues.joomla.org/tracker/joomla-cms/15579.

Add a Comment

Login with GitHub to post a comment