?
avatar Kostelano
Kostelano
13 Jun 2021

Steps to reproduce the issue

#34502 (comment)

In Joomla 3, item state toggle buttons worked (there was classic favorites and item publish states). In Joomla 4, these buttons do not work at the moment, or I don’t understand something (I would be grateful if you could help me figure it out).

The prompts tell us that we can toggle these states.

Screenshot_1

Screenshot_2

avatar Kostelano Kostelano - open - 13 Jun 2021
avatar joomla-cms-bot joomla-cms-bot - change - 13 Jun 2021
Labels Added: ?
avatar joomla-cms-bot joomla-cms-bot - labeled - 13 Jun 2021
avatar chmst
chmst - comment - 13 Jun 2021

The state buttons work as in J3 when you swith off the workflow component.
In J4, as soon ans workflow is enabled, plugins control the transitions from one stage to another and therefore the buttons cannot be acrivated by users. This is intended.

But the message in the tooltips on your screens are wrong. They may not show a coll to action text. So thanks for the hint. Your issue is valid.


This comment was created with the J!Tracker Application at issues.joomla.org/tracker/joomla-cms/34502.

avatar Quy
Quy - comment - 13 Jun 2021

Related #33575

avatar Kostelano
Kostelano - comment - 13 Jun 2021

@chmst Thanks for the clarification, now I understand :)

I will add that the tooltips and action buttons when the workflow is on add more confusion.

For example, select one of the articles and click the UNFEATURE action. As an administrator, I get an error message (see screenshot). First, is it really impossible for an administrator to interfere in this process? Secondly, why then is this action on the list - how to use it?

Screenshot_1

Screenshot_2

avatar chmst
chmst - comment - 13 Jun 2021

@Kostelano I don't know either. This is another issue independent from the first one.

avatar Kostelano Kostelano - change - 13 Jun 2021
Title
[4.0] State toggle buttons do not work / Articles
[4.0] Unfeature action cannot be performed by the administrator / Articles
avatar Kostelano Kostelano - edited - 13 Jun 2021
avatar Kostelano Kostelano - change - 13 Jun 2021
The description was changed
avatar Kostelano Kostelano - edited - 13 Jun 2021
avatar Kostelano
Kostelano - comment - 13 Jun 2021

@Quy I renamed Issue and left a link in the first post to the real problem I described below. So that it does not duplicate the problem you mentioned.

avatar bembelimen
bembelimen - comment - 6 Jul 2021

This was not a useful comment.

avatar bembelimen
bembelimen - comment - 6 Jul 2021

The dropdown is fixed here: #34722

avatar Kostelano Kostelano - change - 6 Jul 2021
Status New Closed
Closed_Date 0000-00-00 00:00:00 2021-07-06 05:40:25
Closed_By Kostelano
avatar Kostelano Kostelano - close - 6 Jul 2021
avatar brianteeman
brianteeman - comment - 6 Jul 2021

Please re-open

avatar Kostelano Kostelano - change - 6 Jul 2021
Status Closed New
Closed_Date 2021-07-06 05:40:25
Closed_By Kostelano
avatar Kostelano Kostelano - reopen - 6 Jul 2021

Add a Comment

Login with GitHub to post a comment