J4 Workflow ?
avatar paternax
paternax
17 Aug 2020

There is a problem with the system notification in Workflow. You have a workflow with a several users. The usergroups of the users based on registered (no administrators), so they and should not receive the "normal" system messages.
If you set the option "Receive System Emails" to "No" in the user configuration the user get also no workflow notification, even if his user group and/or the user is explicitly in the configuration of the transition.

Steps to reproduce the issue

Set up a workflow scenario like. https://docs.joomla.org/Publishing_Workflow/Scenarios/en
But set receive email notification in the user configuration to "No":
screen shot 2020-08-17 at 08 32 20

In the workflow Transition set "Send Notification" to "Yes" and select the Users/Usergroups from the last step
screen shot 2020-08-17 at 08 33 46

Expected result

As a result there should be emails sent to all members of the usergroup "faktencheck" and to the user "checker"

Actual result

In the described configuration the selected usergroup and user get no email.

If you set the options "receive system messages" to "Yes" for all users which are involved the Workflow, each user get all messages from the workflow. Also from the transitions they were not selected.

System information (as much as possible)

Joomla 4.0.0-beta4-dev
PHP 7.3

Additional comments

avatar paternax paternax - open - 17 Aug 2020
avatar joomla-cms-bot joomla-cms-bot - change - 17 Aug 2020
Labels Added: ?
avatar joomla-cms-bot joomla-cms-bot - labeled - 17 Aug 2020
avatar ghost
ghost - comment - 18 Sep 2020

Didn't get a Notification if Receive System Emails is set on Yes or No.

Similaer: #30361

avatar Quy Quy - change - 23 Oct 2020
Labels Added: J4 Workflow
avatar Quy Quy - labeled - 23 Oct 2020

Add a Comment

Login with GitHub to post a comment