No Code Attached Yet
avatar escuta
escuta
31 Jul 2020

Steps to reproduce the issue

After the sysadmin people upgraded PHP on our department's website server from 7.3.x to 7.4.x, the language switcher fails on the bi-lingual website - with certain pages failing to load and navigation getting stuck on the English pages. The website has Joomla! 3.9.20. On my home computer (Debian 10) I installed PHP 7.4.8. While the Joomla! 3.9.20 version of the site fails, an older akeeba backup restore with Joomla! 3.9.10 (also with language switcher 3.5.0) runs perfectly.

My local machine has Apache2 version 2.4.38

The languages installed are Portuguese (Brazil) language pack for K2 (2.5.0) and English (en-GB) Language Pack (3.9.10.1)

avatar escuta escuta - open - 31 Jul 2020
avatar joomla-cms-bot joomla-cms-bot - change - 31 Jul 2020
Labels Added: No Code Attached Yet
avatar joomla-cms-bot joomla-cms-bot - labeled - 31 Jul 2020
avatar escuta escuta - change - 31 Jul 2020
The description was changed
avatar escuta escuta - edited - 31 Jul 2020
avatar HLeithner
HLeithner - comment - 31 Jul 2020

Do you get any error messages?

avatar escuta
escuta - comment - 31 Jul 2020

Ah, yes, I noted on the online version it sometimes gave the following on the home page: "0 Call to undefined function imagecreatefromjpeg()"
It often however jumped to an English language page rather than display the home page. This is what happens on my local version. Also, I use british and brazilian flags on the language switch. With the problem, only the british flag is displayed. Might the "imagecreatefromjpeg" relate to the brazilian flag?
Online, the sysadmin people have temporarily reverted to an an older version of PHP to allow our pages to work.

avatar HLeithner
HLeithner - comment - 31 Jul 2020

in this case your admin doesn't installed all dependencies, I would suggest to add gd2 lib to your php installation

avatar escuta
escuta - comment - 31 Jul 2020

Thank you.

On my system I tried:

sudo apt-get install php7.4-gd
and
sudo apt-get install libgd3

and restarted the apache2 service.

The problem of not displaying the Brazilian flag continues and nor will it display the home page. On my system I don't think I saw the error: "0 Call to undefined function imagecreatefromjpeg()"

avatar HLeithner
HLeithner - comment - 31 Jul 2020

do you have a custom template which overrides the mod_language template?

you can find this in /templates//html/mod_languages/default.php

avatar escuta
escuta - comment - 31 Jul 2020

Yes, perhaps it is a template issue. The file templates//html/mod_languages/default.php doesn't exist however. The site uses a "Joomlart" template called ja_nuevo. The directory templates/ja_nuevo/html contains various mod_* sub directories but none relating to language. I ran in the base directory:

find ./* -name mod_languages -print
./media/mod_languages
./modules/mod_languages
./templates/beez3/html/mod_languages

The template beez3 is not being used.

I also tried changing the template style on the home page that does not load. It continues to jump to the English home page http://127.0.0.1/cen.unb.br/en/ which does not show the brazilian language flag (the default language).

avatar infograf768
infograf768 - comment - 31 Jul 2020

Please test installing on the same server a default core 3.9.20 and its default multilingual data with NO 3pd extensions.

avatar infograf768 infograf768 - change - 2 Aug 2020
Status New Closed
Closed_Date 0000-00-00 00:00:00 2020-08-02 07:23:03
Closed_By infograf768
avatar infograf768 infograf768 - close - 2 Aug 2020

Add a Comment

Login with GitHub to post a comment